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Figure 1, LINC2 Tools Menu - System Design 

 
“The engineering profession applies the principles of mathematics, science, economics, ethics, 
and social sciences to use the materials and forces of nature for the benefit of mankind.1  
This description of the engineering profession, prefacing the undergraduate curriculum in a 
recent bulletin of the school of engineering for a university in the west, elucidates the fact that 
those employed in the engineering profession are engaged in service for society for the benefit of 
humanity.   
 
Thus, we would expect to find not only engineers but the tools they use to be employed in 
businesses, government and private practice of every kind to produce the products and services 
that we all have come to enjoy and in many cases to depend on.  This article will explore this 
concept as it relates to how RF engineering software is making contributions to the field and 
consequently to society.  We will review a small portion of the many ways and places the LINC2 
RF/microwave design and simulation software has been used, looking back over the nearly 
quarter century since its inception.  Then we will present a working design example to illustrate 
how the LINC2 suite of software tools can automate the circuit design process. 
 
In Education: Over the past two and a half decades, the LINC2 design, synthesis and simulation 
software from ACS (Applied Computational Sciences) has been employed by students and 
educators in colleges and universities around the globe.  A sampling of these include Johns 
Hopkins University APL (Applied Physics Lab), Laurel, Maryland; Georgia Tech, Atlanta, 
Georgia; Virginia Tech, Blacksburg, Virginia ; Max Planck Institute for Radio Astronomy in 
Bonn, Germany; Hanbat National University, Republic of Korea; Humber Institute of 
Technology, Toronto, Ontario, Canada; San Diego State University and many more. 



 
In Government: The LINC2 circuit design, synthesis and simulation software has been used in a 
number of government institutions across the country, from NAVAIR at Point Mugu, California 
to the NRL (Naval Research Laboratory) in Washington, DC.  LINC2 has also found 
employment at the national laboratories, including Oak Ridge National Laboratory, Sandia 
National Laboratories and Lawrence Livermore National Laboratory.  Spacecraft engineers also 
find the LINC2 software helpful in designing spacecraft at the NASA Glenn Research Center, 
Cleveland, Ohio and NASA JPL (Jet Propulsion Laboratory) in Pasadena, California. 
 
In Industry: Far too numerous to mention are the many small businesses whose owners have 
found that with LINC2 they can save thousands of dollars on the purchase of RF and microwave 
circuit design software without compromising on the features and capabilities that they need.  
Large businesses are not insensitive to cost either and scores of large businesses have purchased 
the LINC2 software to supplement the CAE (computer aided engineering) software licenses that 
they already own.  Large corporations that have incorporated LINC2 into their design processes 
represent nearly all sectors of industry, from aerospace, medical and bio-engineering to 
consumer electronics of every kind and the cellular telephone industry. 
 
Medicine and drugs: For more than a decade LINC2 has been used in medical research, 
particularly in detection systems.  For example, “NMR [Nuclear Magnetic Resonance 
Spectroscopy] is one of the most information-rich forms of biochemical, chemical, and 
molecular detection and analysis, and remains highly utilized in a wide range of health-related 
industries, including pharmaceutical research and drug discovery.”2  As early as December 1 of 
the year 2000, patent applications were being filed citing LINC2 as the RF software package 
employed to guide the design of these NMR detection probes which use small RF “microcoils”.  
According to the patent filing, “Circuit modeling, e.g., using a commercial RF package such as 
Linc2 available from Applied Computational Sciences (Escondido, Calif.) can be employed to 
help guide the design” of these RF microcoils and their associated impedance matching 
networks, enabling “individual optimization of RF coil sensitivity to different nuclei (1H, 
1H{15N}, 1H{13C}, etc.)”3. 
 
Next we present a textbook example, literally, of one way the LINC2 software might be 
employed to guide the design of the front end of an RF receiver.  The following design example 
closely follows the problem worked out in Example 7.1 – Spur Levels in the book “Practical RF 
System Design” by W. F. Egan.4 
 
Receiver Front End Example 
A spurious response (or spur) in a communications receiver occurs when a signal is present at the 
output which is not a direct response to the desired input signal that the receiver is tuned to.  
Spurious responses can interfere with the desired reception.  Moreover, there are many ways 
spurs can be generated, and their source can be both external (e.g., image, IF and half-IF) and 
internal (e.g., m x LO mixing with n x RF at the mixer or harmonics of digital/clock signals 
coupling into the RX path).  To keep the presentation short and simple, this article will focus on 
the production of m(LO) x n(RF) spurs, how to analyze them and ultimately eliminate or reject 
them. 
 



It is required that a particular receiver be designed to receive signals with levels from -80 dBm to 
a maximum of -15 dBm at 1200.2 MHz.  Additional requirements specify a 10 dB signal-to-spur 
ratio such that the maximum allowed spur referred to the input is -90 dBm (10 dB below the 
weakest desired signal).  This requires any in-band spur to be 75 dB below the maximum (-15 
dBm) input level.   
 
Working out a solution to these requirements is a task for the LINC2 Visual System Architect 
(VSA), a system level simulator from ACS that includes spur analysis as well as cascade budget 
analysis.  At this point we employ the system simulator (Figure 1) because we are interested in 
the accumulated effect of every system component on gain, linearity (which relates to the 
creation of spurs and their levels) and noise figure (NF), etc.  The system simulator will show us 
what these parameters (gain, linearity/P1dB/IP3, NF, etc.) need to be at each stage, and this 
information can be used to design the physical circuit (e.g., low noise amplifier stage). 
 
The LINC2 VSA (Visual System Architect) schematic is opened by selecting “System Design” 
from the LINC2 Tools menu as shown in Figure 1.  The components pertinent to this analysis are 
shown entered into the VSA schematic in Figure 2. 
 

 
Figure 2, LINC2 VSA Block Diagram – Receiver Front End 

 
The initial design starts with an IF at 2000 MHz by employing an LO of 799.8 MHz.  If a spur is 
present it will be strongest at the maximum RF input level, so we start with a signal level of -15 
dBm at the input port and check the spur level in the 2000 MHz IF region. 
 
Clicking Analyze and View > Spectrum Analysis yields the IF spectrum shown in Figure 3.  
From the VSA IF spectrum simulation (Figure 3), we see that there is a 2X3 spur (3*RF - 2*LO 
= 2001 MHz) identified by marker 2 appearing at a level 69 dB below the desired signal (marker 
1).  This worst case signal to spur ratio of 69 dB is 6 dB short of the 75 dB requirement.  The 
deficiency is related to the mixer’s non-linearity.  The mixer could be replaced by another with 
better spur performance (at least for the 2X3 spur) or use a mixer with a higher LO power rating. 
 



There are a couple of things that can be done without replacing the mixer.  First, we can reduce 
the gain ahead of the mixer until the offending 2X3 spur is reduced another 6 dB relative to the 
desired signal.  Secondly, we can choose another IF frequency (by changing the LO frequency) 
to place the IF in a spur free region.  We investigate the first option next. 
 
Option 1: Reduce the front end amplifier gain until the signal to spur ratio is improved by 
6 dB. 
 

 
Figure 3, LINC2 VSA Spectral Plot - Receiver IF Showing 2x3 Spur 

 

 
Figure 4, Reducing LNA Gain to 2 dB Increases the Signal-to-Spur Ratio to 75 dB 

 



We can change the amplifier gain from the Spectrum Graph Tune menu by selecting Tune > 
AMP1, Gain.  Then tap the down arrow key until the gain reduction yields the desired signal to 
spur ratio of 75 dB.  This occurs when the amplifier gain is 2 dB as shown in Figure 4.  (For 
simplicity, the gain of AMP1 represents the net gain of all components prior to the mixer). 
 
We can now select Update Schematic from the Tune menu and rerun the simulation with this 
new gain value (2 dB) to see the effects on other system parameters through to the mixer output.  
With the schematic updated (for AMP1 Gain, Ga = 2 dB), we select Set > Output to add Gain 
and Noise Figure (NF) measurements.  Clicking Analyze and View > Cascade Budget Analysis 
yields the results shown in the graph of Figure 5. 
 

 
Figure 5, LINC2 VSA Cascade Budget Analysis - Receiver Gain and NF 

 
With the gain at only 2 dB ahead of a mixer that has a 10 dB conversion loss, there is not enough 
gain in the LNA (first stage) to hold the NF at 1 dB and thus it rises rapidly through the mixer to 
a total of 8.4 dB at the output.  This would normally be an unacceptable result.  Thus we turn to 
option 2; locating a spur-free region for the IF so that we can increase the gain to improve noise 
figure without incurring the consequences of increased spur level. 
 
Option 2: Choose an LO frequency that places the IF in a spur free region. 
A most invaluable feature of the LINC2 VSA simulator is the ability to change the local 
oscillator (LO) frequency in Tune mode, interactively, while simultaneously observing all the 
resultant signals and spurs in a spectrum analyzer window.  As the LO is moved the IF moves, 



continuously providing new opportunities for a spur free IF.  With the LINC2 Visual System 
Architect (VSA) this can be done visually and interactively in real time. 
 
First, the LNA (AMP1) gain is increased to 15 dB to bring the NF down.  Then the LO is tuned 
while observing the IF move through regions of more or less spurs until we arrive at an 
acceptable IF that is relatively free of spurs.  This is the case for an IF on the low side of an 
1100.2 MHz LO as shown in Figure 6.  (Figure 6 shows the spectral results for a maximum input 
signal of -15 dBm using an 1100.2 MHz LO). 
 

 
Figure 6, LINC2 VSA Spectrum Graph (Lower Plot is Expanded IF Region) 

 



In not defining an IF bandwidth (Figure 2 does not include an IF filter) the problem has been 
kept general so far.  Consequentially, we can see from the expanded IF region (lower Spectrum 
Graph in Figure 6) that there are no spurs in any potential IF bandwidth less than 200 MHz wide 
(<100 MHz either side of the 100 MHz IF center frequency).  The nearest spur, 100 MHz above 
the IF, is approximately 65 dB below the maximum IF signal (Figure 6).  This is a vast 
improvement over the previous IF (at 2.0 GHz) which had a significant spur only 1 MHz away 
from the IF center (Figure 3).  However, the -65 dBc spur is 10 dB short of the requirement.  But 
this is now very easy to remedy with an IF filter.  As shown in Figure 7, we can add a simple 30 
dB (rejection) band-pass filter after the mixer and get nearly 20 dB of margin (minus the filter 
loss). 
 

 
Figure 7, LINC2 VSA Receiver Schematic with IF Filter  

 
With the addition of the IF filter, the spur at 200 MHz drops to -94 dBc as shown in Figure 8.  
This provides 19 dB of margin to the -75 dBc requirement.  And whereas the noise figure was 
8.4 dB using the IF of option 1 (Figure 5), this IF scheme improves the noise figure to very 
nearly 2 dB as shown in Figure 9. 
 
The frequency plan (LO and IF selection) corresponding to a satisfactory gain, NF and spur 
budget is now complete.  The detailed circuit design of the LNA can now commence. 
 
 



 
Figure 8, LINC2 VSA IF Spectrum Simulation - Includes IF Filter 

 

 
Figure 9, LINC2 VSA Cascade Budget Simulation - Gain and NF 

 
 
 
 



LNA (Low Noise Amplifier) Design Example 
In the process of employing the LINC2 VSA system simulator to select a workable frequency 
plan, and work out other system level requirements, the software is also developing the stage-by-
stage requirements that can be used to direct the low level circuit design of each stage in the RF 
chain.  The low noise amplifier (AMP1) in Figure 7 met all our stated requirements so we can 
use it, and the parameters attached to it, as specifications for the next phase of the design – the 
low level circuit design. 
 
From Figure 7 the candidate transistor must have a minimum noise figure, Fmin, less than 1 dB 
with an associated gain of approximately 15 dB.  Regarding linearity, the device will have an 
input P1dB = 0 dBm and an input third order intercept point IIP3 = +9.64 dBm. 
 
LINC2 LNA design is started by selecting “Amplifier Design > Low Noise Amplifier” from 
the Tools menu.  Loading the s-parameters, including embedded noise parameters, for the 
NESG2021 candidate device into the LINC2 LNA design tool and selecting the operating 
frequency opens the LNA design environment shown in Figure 10. 
 

 
Figure 10, LINC2 LNA Design and Circuit Synthesis Tool 

 
The Circles utility of Figure 10 indicates that the selected NPN SiGe transistor is potentially 
unstable at the 1200 MHz operating frequency.  This is evident by stability circles that are 
displayed intersecting the Smith Chart in both the input and output planes.  There are at least a 
dozen methods for LNA design or analysis included in the LINC2 LNA Circles utility, including 
one devoted entirely to device stability analysis and remedial solutions. 
 
The LINC2 Circles utility can automatically stabilize the potential instability of the device or 
transistor by employing the user’s choice of several methods.  For this example a 240 Ohm load 



resistor is inserted in series with the output terminal.  This action stabilizes the transistor and 
drops the gain from a potentially unstable excess of 22.8 dB (Figure 10) to an unconditionally 
stable 15.24 dB (Figure 11).  As will soon be shown, 15.24 dB of gain will be just enough to 
account for the anticipated loss in the input and output matching networks and still meet our 15 
dB requirements for the completed LNA. 
 

 
Figure 11, LINC2 LNA Matching Network Synthesis 

 
Designing a low noise amplifier at the transistor level often involves the application of an 
intentional mismatch at the input in order to present the transistor with the optimal source 
impedance for minimum noise, Fmin.  This “noise match” reduces the gain available from the 
overall amplifier.  There may be additional reasons why a “noise match,” that incurs a conjugate 
mismatch, may be undesirable (from an external or system point of view).  Thus, LINC2 LNA 
design provides alternative design methods for automating various trade-offs between gain, noise 
figure and input, as well as output, return loss.  For this example, the optimum noise match was 
selected (Figure 11). 
 
Selecting “Transmission Line > Stub and TRL Cascade” from the Match menu automatically 
synthesizes the RF LNA schematic shown in Figure 12 with ideal series and shunt transmission 
lines.  The initial synthesized circuit schematic is immediately ready to analyze to verify the 
amplifier’s performance (by simply clicking “Analyze”).  Simulating the circuit with ideal 
transmission lines will give a very good indication of the amplifier’s performance.  But the 
transmission lines are electrical models (characteristic impedance, Z0, and electrical length in 
degrees, etc.) and we cannot directly lay out the printed circuit board with electrical models; we 
need physical microstrip models.  Fortunately, LINC2 can automatically convert all the 
transmission lines in the circuit schematic to microstrip or stripline in a single step. 
 



Clicking “Auto > Convert T-Lines To…> Microstrip” pops up a substrate definition dialog 
box for specifying the board material.  For this example, Rogers RT/duroid® 6010LM 25 mil 
laminate is selected.  Immediately the microstrip circuit of Figure 13 is created.  All the 
transmission lines in the initial LNA circuit of Figure 12 are automatically converted to the 
microstrip circuit of Figure 13 while shunt stubs TL1 and TL4 are here utilized as bias feed lines 
for the power supply; these become MLI3 and MLI4 respectively in the schematic of Figure 13.     
 

 
Figure 12, LINC2 Synthesized LNA 

 

 
Figure 13, LINC2 Synthesized LNA Designed with Microstrip 

 
Clicking “Analyze” and “View Plot” runs the circuit simulation and displays the LNA gain and 
output return loss performance as shown in Figure 14.  Figure 14 indicates that after accounting 
for the loss in microstrip and board material the LNA still maintains 15 dB of gain at the 1200 
MHz operating frequency.  The output return loss is greater than 36 dB while the input is 
matched for minimum noise figure (< 1dB).  This completes the circuit design of an LNA that 



meets the system level requirements discovered using the LINC2 Visual System Architect 
software. 
 

 
Figure 14, LINC2 Gain and Output Return Loss Simulations 

 
Summary 
Many products involving RF consist of multiple stages. For example, the signal path in a radio 
receiver may pass first through a filter, low noise amplifier, a mixer or down-converter and 
possibly an IF stage consisting of filtering and more amplification at the intermediate frequency. 
The characteristics of each stage interact with the characteristics of the other stages necessitating 
the proper balance of the stage-by-stage parameters in order to meet the overall product 
specifications.  The product design must therefore begin at the system level because the 
parameters of each individual stage remain fluid until the cascade budget analysis indicates that 
the product specifications are fulfilled.   
 
When the system simulator arrives at a workable solution all the parameters of each stage (gain, 
NF, IP3, P1dB, etc.) have been determined for each individual stage and the design turns to 
creating the circuit level implementation of each particular stage.  The LINC2 software provides 
the design solution at both the system and circuit levels so that the overall product design can 
properly flow from high level design using the LINC2 VSA to low level circuit design using 
LINC2 Pro circuit synthesis and simulation.  This article demonstrated this concept of design 
flow by first considering the frequency plan and other high level issues, such as total noise figure 
and a spurious free dynamic range, and then proceeding to the detailed design of the LNA. 



 
The LINC VSA was used to identify the spurs of interest and their relative amplitudes.  It is a 
fairly easy matter to predict the frequencies of the spurs but it is significantly more difficult for 
the simulator to determine the exact amplitude of every spur.  There are a number of reasons for 
this; some lie in the hardware itself (e.g., unaccounted for leakage paths) while others depend on 
the simulator and the type of models used.  LINC2 offers several types of mixer models with 
varying degrees of approximation to any given type of real mixer. 
 
In the LINC2 VSA, the simplest mixer model accounts for gain/loss, NF, and non-linearity in the 
budget simulation but not frequency translation. All other LINC2 mixer behavior models include 
some form of frequency translation.  Only the advanced model, still under development and used 
here in this presentation, models the frequency translation in addition to spurs created by the LO 
to RF interaction.  Another approximation is that the simulator’s model parameters are constant 
over frequency whereas that is usually not the case for real mixers (over extremely wide 
bandwidths).  There are a number of filter models in the components pallet that can be used to 
model the frequency response.  Nevertheless, the VSA simulator can be a very useful tool in 
determining the location of the spurs in almost any kind of spur situation. 
 
Conclusion 
The Visual System Architect from ACS adds many built-in simulation functions for producing 
the stage-by-stage cumulative system budget analyses that are essential for successful system 
design, analysis, system performance verification and report generation.  Full spectral domain 
analysis provides a spectrum analyzer view of the signals and spurs at any point in the system. 
 
While providing many new design and analysis capabilities for designing at the system level, the 
VSA program maintains a common user interface with the ACS LINC2 circuit simulator.  With 
the VSA addition to the LINC2 Pro circuit design and simulation software suite, system level 
designs created with the Visual System Architect can proceed to the detailed circuit design level, 
all within a common integrated user interface.  Thus RF and microwave circuit design can be 
appropriately driven by high level system design that links product specifications to circuit level 
specifications and subsequently to detailed circuit designs that meet product requirements. 
 
At the circuit level, LINC2 provides high performance RF and microwave design and simulation.  
In addition to schematic based circuit simulation, optimization and statistical yield analysis, 
LINC2 Pro includes many value-added features for automating design tasks, including circuit 
synthesis.  Filter synthesis, amplifier circuit synthesis (including LNA synthesis), the automated 
synthesis of impedance matching networks and coupler design are just some of the LINC2 Pro 
automated synthesis modules. 
 
More information about the ACS Visual System Architect and LINC2 Pro can be found on the 
ACS web site at www.appliedmicrowave.com. 
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