
Chapter 3 
 

 Program Menus, Options, and Settings 
 
 
3.1 The Main Menu: Schematic Window 
 

The File Menu: 
• New clears the schematic page and prepares the program for a new schematic 

capture or synthesis session. 
• Open Schematic pops up a “File Dialog Box” for opening an existing schematic. 
• Save Schematic pops up a “File Dialog Box” for saving the currently displayed 

schematic. 
• View Netlist shows the netlist for the currently displayed schematic. 
• Save Netlist… saves the currently displayed schematic in netlist file format. 
• Open S-Param File… loads S-parameters from a data file into the program for 

display or analysis. If the “Perform Single Frequency Analysis” box is left in the 
default (checked) state, then the Circles Utility will start with the specified S-
parameter file. Unchecking this box loads the S-parameters into the program for 
direct viewing in the rectangular graph or Smith Chart windows.  Select Options | 
Sweep to set up the band and number of (interpolated) frequency points over 
which to view the imported S-parameter data. 

• Save S-Param Data… saves the S-parameter results of a circuit simulation to a 
data file. 

• Open *.CKT (Text) File… Runs a simulation on a circuit file in netlist format. 
After opening a netlist (CKT) file, the simulation results can be displayed from 
the main View menu. The loaded netlist circuit file can be viewed by selecting 
Edit *.CKT (Text) File… from the main File menu. 

• Edit *.CKT (Text) File… opens a full-screen text editor for generating and 
editing circuit netlists, data files, and other text files. 

• Print Setup… accesses printer options. 
• Print Schematic prints the currently displayed schematic window. 
• Exit Schematic exits from the schematic page. Clicking Exit again quits the 

program entirely. 
 

The Edit Menu: 
• Undo reverses the last operation. 
• Copy Part enables making a duplicate of any part already placed on the 

schematic page. After selecting Edit | Copy Part, press the left mouse button 
down over any existing part and drag its copy to a new position on the schematic. 



Another way to duplicate a part is to first hold down the SHIFT key and then left 
click down over any part. Drag and drop the duplicate part to its new position. 

• Select All selects all parts on the schematic. The outline of selected parts changes 
from black to red when selected. Parts selected can be deleted or moved as a 
group. Moving parts will delete their connections unless “Move All” is selected. 

• Deselect All unselects all parts that were previously selected (parts outlined in 
red). 

• Move All moves all parts on the page to a new position (drag-and-drop mouse 
action). 

• Move Selected moves all selected (highlighted) parts to a new location on the 
page. The wire connections to all moved parts will be deleted. 

• Delete Last deletes the last part placed. 
• Delete Selected deletes all selected parts. Individual parts can be selected by 

clicking the right mouse button over the part. The color of a selected part changes 
to red. Clicking “Delete Selected” when no part is selected changes the shape of 
the mouse pointer to cross-hairs. Place the cross-hairs over the part and click 
either mouse button to delete the selected part. All connections to the part will 
also be deleted. The keyboard Delete key can also be used. 

 
The Parts Menu: 

The Parts menu displays the available parts and their placement orientations. 
Selecting a part from the menu drops it onto the schematic page and opens up a Part 
Parameter Dialog Box. The Part Parameter Dialog Box allows for editing the part’s 
name, value(s), comments, and whether or not it can be tuned (or available for statistical 
analysis in the “Statistics” window). See Section 4.2 for part descriptions. 

 
The Wire Menu: 

Clicking on Wire starts placement of a wire connection between the terminals of a 
part or parts. Wire placement must begin by clicking the left mouse button over the 
terminal point of a part (little circle at the end of its lead). As the wire is routed, it can be 
anchored at any point on the schematic page (in order to change direction) by clicking the 
left mouse button. Multiple part pins (part terminals) can be connected at one time by 
continuing to click the left mouse button over each pin to be connected. However, the last 
pin to be connected at the end of the wire must be clicked with the right mouse button. 
To delete a wire, left click on it to highlight the wire in red and then press the Delete key. 
(In some cases all wires connected to the node may be deleted.) Note:  It is not necessary 
to select the Wire menu to place a wire. The process of placing a wire connection can be 
started by simply left clicking on a part pin. Wire placement starts by clicking the left 
mouse button on a pin and ends by clicking the right mouse button on a pin. 
 



The Set Menu: 
The Set menu provides for the selection of various options and for controlling (or 

formatting) the output of the simulator. 
 

• Frequency Sweep sets the frequency range and number of points over which the 
simulation will run (produce output). 

• Sweep Markers sets the frequency markers that are used to display output data at 
four specific frequency points in the “GRAPH” window after the simulator has 
analyzed the circuit. If “Auto” is unchecked, then Markers 1 through 4 will be 
available for setting each frequency point manually. If “Auto” is checked, then all 
four markers will be set automatically at evenly placed points throughout the 
frequency range. 

• Grid places a grid on the screen to aid in the placement and alignment of parts 
and wire traces. The grid can be turned on or off, or made light or dark. 

• Traces provides control over the way wire traces can be routed on the schematic 
page. “Horizontal/Vertical Only” is the default and preferred method since it 
helps to keep the lines straight. However, occasionally it may be necessary or 
desirable to place a wire at a 45° angle or some other orientation. “Any 
Orientation” provides this flexibility if needed. 

• Output pops up a “View Options” dialog box. This allows selecting what will be 
plotted in the “GRAPH” window after the circuit is analyzed. It also sets up the 
vertical scale(s) of the plotted data. 

• Snap to Pin... adjusts the snap distance for connecting a wire to a part pin. 
• Show Nodes displays the node number of each connection next to the part pins on 

the schematic page. 
 

The Design Menu: 
• LNA (Circles Utility) launches the Single Frequency Analysis (Circles) tool for 

analyzing and synthesizing low noise and maximum gain amplifiers. 
• Clicking Amplifier(s) will synthesize a single or multistage amplifier schematic 

depending on the information entered into the Design Specifications form. If the 
schematic page is not initially blank, then File | New must first be selected to clear 
it. 

• Match generates an impedance matching network between any unbalanced source 
and load port placed on the schematic page. The type of matching network is 
specified by the Input Matching tab of the Design Specifications form. If the 
schematic page is initially blank, then impedances to be matched will be found on 
the Ports tab of the Design Specifications form. 

• Convert T-Lines to… converts certain transmission lines present in the schematic 
from their electrical representation to physical representations as microstrip or 
stripline. 



• Preferences/Design Specs pops up the Design Specifications form for user 
control over the design characteristics of the amplifier or matching networks 
synthesized. 

 
The Analyze Menu: 

This menu button starts the simulation engine analyzing the circuit schematic. A 
successful simulation produces analysis results available for display by selecting the 
method from the View menu. 
 
The View Menu: 

• Smith Chart displays a graphical view of the complex (vector) quantities S11 and 
S22 for the analyzed circuit. The S-parameters from a data file can also be imported 
directly and displayed on the Smith Chart. To display S-parameters from a data 
file, select File | Open S-Param File…, uncheck Perform Single Frequency 
Analysis, and click OK. Marker data can be displayed at the bottom of the window 
in decibel or linear formats or as complex (real and imaginary) input and output 
port impedances. The display options can be changed by selecting View | Set 
Options or Options | Display. 

• Plot (Rectangular) produces a rectangular plot of selected circuit responses or S-
parameter data. 

• Results (Table) presents a table of all circuit responses or S-parameter data. 
• Stability displays stability circles for the circuit or S-parameter data at selected 

frequency points. 
• Statistics opens a window for performing Monte Carlo statistical and yield 

analysis. 
• Set Options opens a form for selecting the data to be displayed and the vertical 

scales for rectangular plots. 
 
The Options Menu: 

• Set Colors sets the trace colors of plots and grid lines. 
• Display options are plot trace thickness, display grid lines on rectangular graphs, 

and display magnitudes in linear or decibel format. 
• Performance sets the maximum number of simulation sweep points. The default 

number of points is 1001. However, setting this number lower, to 401 or 201 
points, may enable the program to run on computers with less memory and 
processor speed. 

• Sweep is used to set up the band and number of (interpolated) frequency points 
over which to view imported S-parameter data. Enter the Start Frequency, Stop 
Frequency, and number of points after importing an S-parameter file for analysis. 
Sweep does not set the simulation sweep frequencies. Use Set | Frequency 
Sweep… to specify the simulation sweep frequencies. 

 



The About Menu: 
• About displays the current version number and copyright information. 

 
The Current File Menu: 

When a previously saved schematic file is loaded from the File menu, the file 
name appears in the main menu bar just to the right of the About menu. Clicking on the 
file name in the menu bar pops up an Open File dialog box for loading another schematic 
file. When the schematic page is cleared, this filename menu is not displayed. 

 
The Warnings Menu: 

If an error occurs during simulation, a Warnings menu may appear as the last item 
on the main menu bar. The options listed are: 

• View the simulation warning messages in a separate window with the following 
File options: 

• Save Error File As… saves the warnings to a disk text file. 
• Print Error File sends the warning messages to the printer. 
• Exit Warnings closes the message window and returns to the schematic 

page. 
• Clear removes Warnings from the menu bar and clears the message file. 
 

3.2 The Text Editor 
 

A full-screen text editor is provided for generating and editing circuit netlists, data 
files, and other text files. When the Text Editor contains a circuit netlist, a circuit 
simulation can be launched directly from this window. 

Selecting Edit *.CKT (Text) File… from the main File menu opens the Text 
Editor with the following menu options: 
 
The File Menu: 

• New | Clear clears the contents of the Text Editor. 
• New | Circuit Template provides an outline of a circuit netlist. A text-based 

description of a circuit can be constructed by editing this file. 
• Open… pops up an Open File dialog box for loading circuit (CKT) files into the 

editor. 
• Save As… saves the contents of the Text Editor to a disk file. 
• Print Text prints the contents of the Text Editor. 
• Analyze Circuit launches a simulation of any valid circuit file displayed in the 

Text Editor’s window. Upon successful simulation, a pop-up menu will offer 
various methods for viewing the results. 

• Circles Utility launches a simulation of any valid circuit file displayed in the Text 
Editor and subsequently invokes the Circles Utility using the resulting S-
parameters. 



• Exit returns control to the schematic window. 
 
The Edit Menu: 

• Cut removes selected text and places it on the Windows clipboard. 
• Copy places a copy of selected text into the clipboard. 
• Paste copies any text from the clipboard to the current cursor location in the Text 

Editor. 
• Select All selects and highlights the entire contents of the Text Editor. 
 

The Analyze Menu: 
This menu duplicates the function of Analyze Circuit in the File menu by 

launching a simulation of any valid circuit file in the Text Editor. 
 
The Settings Menu: 

• Settings | Colors sets the foreground (ForeColor) and background (BackColor) 
screen colors. 

• Font Sizes sets the font size for displayed text. 
 
The About Menu: 

About… displays a message describing the intended purpose of the Text Editor. 
 
3.3 The Single Frequency Analysis (Circles) Window 
 
The File Menu: 

• Open S-Param File… loads an S-parameter data file into the circles utility for 
analysis and design. 

• Save S-Param Data… saves S-parameter data from the circles utility, including 
data modified in the utility (stabilized device data). 

• Print Window prints an image of the window. 
• Exit closes the Single Frequency Analysis (Circles) window without generating a 

schematic design. 
 
The Frequency Menu: 

• Next advances to the next analysis frequency. 
• Previous steps back to the previous analysis frequency. 
• Select displays a list of frequencies. Any frequency in the list can be selected for 

the current analysis frequency. If a desired frequency is not listed, then new 
frequency data can be entered via the Frequency | Sweep menu that captures the 
desired frequency point. 

• Sweep defines a set of up to 21 frequency points. The start, stop, and number of 
frequency points can be specified. If any of the frequency points do not line up 



with the frequencies in the original data file, then the program will interpolate (or 
extrapolate) the data at the frequency point that doesn’t match the file. 

 
The View Menu: 

• Stability displays stability circles and related stability data for the selected 
frequency. 

• Gain, Ga displays a constant available power gain circle on the input plane for a 
given gain and frequency selection. All points on the circle represent source 
reflection coefficients (ΓS) that will produce the desired gain. These are mapped to 
a circle in the output plane. Each point on the output circle represents a conjugate 
output match (ΓL) for every ΓS (on the Ga circle) applied to the device input. Any 
point on the constant available power gain (Ga) circle can be selected by dragging 
the point around the circle with the left mouse button or by selecting CW 
Clockwise or CCW from the Move menu. The corresponding point on the output 
circle will be automatically updated. For every ΓS and ΓL combination selected, 
the gain remains constant. To select a different gain (and hence a different Ga 
circle), click View | Gain, Ga and enter a new value or right click anywhere within 
the input Smith Chart. 

• Gain, Gp displays a constant operating power gain circle on the output plane for a 
given gain and frequency selection. All points on the circle represent load 
reflection coefficients (ΓL) that will produce the desired gain. These are mapped to 
a circle in the input plane. Each point on the input circle represents a conjugate 
input match (ΓS) for every ΓL (on the Gp circle) applied to the device output. Any 
point on the constant operating power gain (Gp) circle can be selected by dragging 
the point around the circle with the left mouse button or by selecting CW 
Clockwise or CCW from the Move menu. The corresponding point on the input 
circle will be automatically updated. For every ΓL and ΓS combination selected, 
the gain remains constant. To select a different gain (and hence a different Gp 
circle), click View | Gain, Gp and enter a new value or right click anywhere within 
the output Smith Chart. 

• Noise and Ga: 
• Tracking keeps the noise and gain circles locked and intersecting at a common 

impedance point. The impedance point (ΓS, or source gamma in the input 
plane) can be selected anywhere within the Smith Chart by a simple click of 
the right mouse button. Both circles will snap to that point and the usual 
printed data in the information block at the bottom of the page will be updated. 

• Independent allows for controlling the gain and noise circles separately. The 
size of gain circles can be changed by right clicking on the Smith Chart (or 
dragging the gain circle to a larger or smaller value using the right mouse 
button). In addition, the mouse can control the impedance point on the gain 
circle. Just click any point on the circle with the left mouse button or drag the 



impedance point around the circle. Noise circles can be increased or decreased 
in size by tapping the “+” or “ -” keys. 

• Tradeoffs lets you make gain or noise tradeoffs instantly. A slider control (or 
Scroll Bar) appears on the screen under the input Smith Chart. The left end of 
the scroll bar is designated “Max Gain” and the right side “Min Noise.” Simply 
slide the bar to the left to increase gain or to the right to decrease noise figure. 
The gain and noise circles stay locked together as the source 
reflection/impedance point, ΓS, moves along an optimum path between 
minimum noise and maximum gain. 

• Maximum Gain: 
• MAG (Gmax) displays the maximum available gain (MAG) for the device. 

The MAG is unavailable if the device is potentially unstable. In most cases it 
can be stabilized unconditionally at the frequency of interest by selecting one 
of the methods from the Options | Stabilize Device menu. A point is plotted on 
the Smith Chart in each of the input and output planes. The points represent the 
ΓS and ΓL device terminations that will produce maximum available gain. The 
numerical values of the corresponding source and load reflection 
coefficients/impedances are printed at the bottom of the screen. 

• Noise and MAG produces all the data and displays as in MAG (Gmax) above 
with the addition of noise circle and noise data. The noise figure in decibels 
(when the device is terminated for MAG) is reported and the appropriate noise 
circle is plotted. The noise circle intersects the point ΓS = Γmax. 

• Minimum Noise:  
• Minimum Noise (Fmin) plots the input match point (ΓS = Γopt) for the 

minimum noise figure. The conjugate match point is also plotted in the output 
plane.  The gain, noise, and matching impedances are printed at the bottom of 
the screen. Since the device is matched for minimum noise rather than 
maximum gain, the input VSWR will be greater than 1. 

• Fmin and Gain (Ga) produces all the data and displays as in Minimum Noise 
(Fmin) above with the addition of plotting a gain circle and related circle data. 

• Stability On turns stability circles on (checked state) or off (unchecked state). 
• Freq Sweep when checked enables plots of stability circles, gain circles, 

minimum noise match points and gain match points over a sweep of frequencies. 
• Clear erases all plots and data displays and disables Freq Sweep. 
 

The Move Menu: 
• Fast sets the maximum step size for controlling gain and noise circles. Also sets 

the step size for traversing (moving the impedance match point) around circles. 
• Medium sets the step size to medium for controlling gain and noise circles. Also 

sets the step size for traversing (moving the impedance match point) around 
circles. 



• Slow sets the smallest step size for controlling gain and noise circles. Also sets the 
step size for traversing (moving the impedance match point) around circles. 

• CW (Clockwise) moves an impedance match point around a gain circle in the 
clockwise direction. 

• CCW moves an impedance match point around a gain circle in the counter-
clockwise direction. 

 
The Match Menu: 

The Match menu produces the final output from the Circles Utility and then exits the 
utility. The result is a complete circuit synthesized with matching networks that extract 
the desired power gain and noise performance from the device. When source and load 
reflection/impedance points are plotted in the input and output planes, respectively, then 
the following matching networks can be selected from the Match menu to match the 
device. Upon selection of a matching network topology, a circuit netlist will be placed in 
the Text Editor or a schematic diagram of the circuit will appear in the schematic window 
(depending on the export method specified in the Match | Export Output menu). 

• L Match provides all the available “L” match configurations for the input and 
output networks. Click “Select Input Match” or “Select Output Match” to specify 
the type of input, or output match, respectively. 

• T Match specifies a T-matching topology at the input and output of the device. 
The phase shift through each network can be specified. This provides control over 
the component values and circuit Q. 

• PI Match specifies a Ð-matching topology at the input and output of the device. 
The phase shift through each network can be specified. This provides control over 
the component values and circuit Q. 

• T-PI Match specifies a T match at the input and a Ð-matching topology at the 
output of the device. The phase shift through each network can be specified. This 
provides control over the component values and circuit Q. 

• PI-T Match specifies a Ð match at the input and a T-matching topology at the 
output of the device. The phase shift through each network can be specified. This 
provides control over the component values and circuit Q. 

• Transmission Line: 
• Single Section matches the device input and output with a single section of 

transmission line. 
• 1/8 and 1/4 Wave Cascade matches the device input and output with eighth- 

wave and quarter-wave transmission line sections. 
• Stub and TRL Cascade matches the device input and output with open or 

short stubs and transmission line elements. 
• Export Output directs the circuit synthesis output to the following locations: 

• To Netlist Editor: The Text Editor receives the synthesis output. 
• To Schematic: The schematic window receives the synthesis output. 

 



The Options Menu: 
• Target Z0in sets the input port impedance. The input matching network 

transforms this impedance to the appropriate value required at the input terminal 
of the device. The default value for Z0in is 50Ù. 

• Target Z0out sets the output port impedance. The output matching network 
transforms this impedance to the appropriate value required at the output terminal 
of the device. The default value for Z0out is 50Ù. 

• Stabilize Device 
• Series Load Resistor uses a resistor in series with the output terminal to 

stabilize the device. 
• Shunt Load Resistor uses a resistor in shunt with the output terminal to 

stabilize the device. 
• Common Lead Inductance places an inductor between the common 

(otherwise grounded) device terminal and ground. This provides output to 
input series feedback. 

• Reset S-parameters removes the stability resistor or inductor and returns the 
S-parameter set to the original device or transistor’s S-parameters. 

• Show G=1 Circle displays the unity conductance circle. 
• Show Circles > MSG removes the restriction of only allowing gain circles to be 

displayed up to the approximate maximum stable gain region on the Smith Chart. 
When a transistor is potentially unstable, it may be useful to explore gain circles 
and stability circles beyond the stable region. Of course, much of the matching 
conditions at or above MSG will be invalid for amplifier design. 

 
The Current File Menu: 

The current device file name appears as the last item on the menu. Clicking on the 
file name in the menu bar pops up an Open S-parameter dialog box for loading another 
data file.   
 
3.4 The Monte Carlo Statistics Menus   
 
The Yield Menu:  

Calculates the YIELD based on the response goals and component tolerances. Up 
to four goals can be set up for each of two circuit responses. This allows for a circuit 
response to have different goals for different frequencies. The responses available are 
those previously set up from the main View | Set Options menu or through the Set | 
Output… menu prior to analyzing the circuit.  
 

If Graph | Show Graph is checked, then the cumulative responses of all the Monte 
Carlo runs will be displayed in a graph window. Clicking YIELD from the graph window 
will return to the goal/yield window. 

 



The Tolerances Menu: 
Lists all the components that have been selected for tuning. During a Monte Carlo 

run, each element listed here will be varied uniformly over a range of values. Selecting 
any one from the list will pop up a Set Tolerance input box. A new tolerance (+/- percent 
value spread) can be entered, or the default +/- 5% uniform distribution can be accepted. 
 
The Set Menu: 

• Sample Size specifies the number of times the circuit will be evaluated while 
varying component values over their specified range. 

• Reset Tolerances resets all circuit component variations to a specified range. 
 
The Graph Menu: 

• Graph | Show Graph displays cumulative responses of all the Monte Carlo runs 
in a graph window when the Calculate Yield button is pressed. 

• Graph | Return Statistics exits the graph window and returns to the goal/yield 
window. 

 
The Print Window Menu: 

Prints an image of the current statistics or graph window. 
 
The Exit Menu: 

Exits the Monte Carlo Statistics window. 
 
3.5 The Graph Menus 
 
The Markers Menu: 

• Markers | Markers On enables four markers to display response data at four 
frequency points. A Markers form displays the data numerically at each point. 

• Markers | Set Markers sets the marker frequency for each marker. 
 
The Tune Menu: 

• The Tune list contains all the components available for tuning. The component’s 
name and/or its nodal position in the circuit netlist is given. Selecting a component 
from the list displays its value in the graph window’s menu bar. To change its 
value, click on the value displayed in the menu bar or tap the UP (↑) or DOWN 
(↓) arrow keys. 

• Reset Variables returns all components to their value(s) before tuning. 
 
The %Change Menu: 

This menu changes the tuning percentage from the default value of 5%. 
 



The Print Window Menu: 
This menu prints an image of the graph window.  

  
The Current Tune Component: 

If a component has been selected for tuning from the Tune menu, then it will be 
displayed as the last item on the menu bar. Clicking on the current component in the 
menu bar pops up an input box for changing its value.   
 

Clicking [X] closes the graph window. It is a good idea to turn Markers off by 
unchecking Markers | Markers On before closing the graph window. This helps to 
ensure that new marker data will be recalculated properly the next time a graph window 
is opened. 
    

  
 


